It appears that Microsoft Windows Server in its default configuration has a critical vulnerability that can cause an escalation of privileges if a server is compromised.

This is known as the Juicy Potato exploit.

Microsoft does not want/plan to fix/patch this vulnerability and forces customers to upgrade to Windows 2019.

As a temporary measure, we have to disable DCOM on all Windows servers - this should not affect Plesk control panel but it may affect some of the websites if your scripts rely on DCOM. Long term solution will be to upgrade to Windows 2019 but this cannot be done in-place. We will have to prepare new servers with Windows 2019 and then migrate customers to it. All affected customers will be informed about this migration.

You can read more about this on https://support.plesk.com/hc/en-us/articles/360010138760

Regards

Vladimir Aleksic
L3 Admin
Fluid Hosting



Friday, December 20, 2019

« Back